Sonic Pad Bed Mesh issues with Ender 3 S1 Pro

I have an issue where my Sonic Pad and Ender 3 S1 Pro don’t seem to get along. I am only having issues with the Bed mesh not being used when printing. This makes the whole prints fail right from the 1st layer. Does anyone have any suggestions on how to get the Sonic Pad to use the saved bed mesh for the Ender 3 S1 Pro?

Hi @ManixKorax and welcome to the forums!

If you can try checking the printer.cfg file on the Sonic Pad and see if the G29 section is commented out. The section would start with something like [gcode_macro G29]
Remove any # symbols that may be in front of that macro, save the config and try printing.

Thank you for the Welcome!
In my print.cfg file there is no G29 line at all. Can you please provide me with a G29 example that I can use in the print.cfg?

I have not used the S1 Pro myself but the gcode for the macro should be something like the following…

[gcode_macro G29]
gcode:
  G28
  bed_mesh_calibrate
  G1 X0 Y0 Z10 F4200
  save_config

Hope that helps

I will give that a try tonight. Thanks for the help.

1 Like

So far it has not helped with this printer. I have tried Klipper guides on this topic and none of them have helped. I am going to test the printer by using Marlin and see if I get different results in the first layer results. Thanks again for the help.

1 Like

Sorry to hear that it hasn’t helped. It definitely sounds like something is not properly configured in the Klipper side of things. Do keep us informed on how you get on with Marlin :slight_smile:

Hi folks. I got the exactly same issue: bed mesh compensations is not working on my Ender S1 Pro with SonicPad :frowning:
I did all suggestions over the internet, but any of then works. My section on printer.cfg is:
[gcode_macro G29]
gcode:
G28
bed_mesh_calibrate
G1 X0 Y0 Z10 F4200
save_config <— this line was originaly commented out, I remove the # to enable it, but still the same issue

I printed a bed leveling pattern without PLA filament and I can see that there is no compensation during the head movements…

Hi @Eduardo_Melo and welcome to the forums.

I would recommend following the video below to see if there are any tips or pointers that might help you resolve your issues.

Creality Sonic Pad - Easy Klipper for the S1 Pro

hello!

I followed all the tips not only in this video, but in several other videos, trying to solve this problem.

As I mentioned before, although the bed mesh worked perfectly saving the parameters, it appears that the SonicPad/Klipper ignored them.

There is no compensation using saved mesh points during head movements. So sonicpad is useless for S1 Pro users that doesn´t have a perfect flat bed.

I bought it just because is hard to get a flat bed and a good bed mesh compensation could save time and money, but I stuck on this issue.

Seems that kipper (or sonicpad) is not compensating the z coordinates using the saved mesh… I tried all tutorials on Internet…please someone have any other tip?

Hopefully someone with a similar setup can offer some advice.

There was a minor improvement in 1st layer print after moving back to Marlin. Not what is was before i switched to Sonic Pad. Due tonthe holiday season i am not able to test agin. I will get back to it soon though.

1 Like