Sonic Pad Display Looping

I tried updating to the latest firmware. Now my display is looping the Creality loading screen. I can connect to the web interface, but am less comfortable running the printer in this format.

When I try to enter Burning mode the device does not show on the computer. Any assistance would be greatly appreciated.

Hi @Andy_Dutcher welcome to the forums.

I would recommend performing a manual firmware update by downloading the latest firmware from the following page, extract the archive and place the 2 update files (config.ini and t800-sonic_lcd-ab_1. onto a USB stick and insert into the Sonic Pad, if all goes as planned the pad should update or prompt for the update to be applied.

Sonic Pad Downloads & Firmware

If this fails I would recommend contacting support to see if they are aware of a known issue such as this.

Thanks for your response. Should I try a specific USB port? I have tried this a few times, but no luck.

Support wants me to flash the device using the Phoenix suite. However, sonic pad isn’t detectable by a computer in debug mode. I am within the return window, and am about to send for an exchange.

Sorry to hear the firmware didn’t apply using that method. It could be that the Sonic Pad will only read the update once its booted up.

I would recommend reveiwing the following video to see if there is anything you can pick up from the video that might help you with getting Phoenix suite working properly.

Creality Sonic Pad System Restore Tutorial Windows

If all else fails I would return the unit for an exchange.

1 Like

Thanks Nikoli. I have started the exchange process. Hopefully, the new sonic pad will update as expected.

1 Like

You’re welcome Andy. Hopefully the replacement pad will turn up quickly for you. Definitely sounds like a random glitch that happened with your original one as I did the Sonic Pad update today on my pad to test and it seems to have installed ok for me.

Use USB port 1, the upper left hand USB port.