Sonic Pad no longer keeps the connection to my Ender 3 Max Neo

I have tried several times to reset and or connect my Ender 3 Max Neo to my Sonic Pad. This all started to happen after your latest software upgrade. The system looks like its going to work until it gets to adjusting the table. It centers the extruder on the table, adjusts the Z axis, then it give me the pink/orange screen that says:
Internal error on command: BED_MESH_SET_DISABLE. I tried the suggested work arounds but nothing works. What should I do before getting my sledge hammer?

Known issue, need to wait for firmware fix.

Be the first to be notified when there’s news.

Thank you very, very much. I will be waiting.

Ok, got the new firmware, loaded it, seem to work until I tried to manually level my printer. After leveling my printer I tried to do an auto-Level and Got and error code key281, and it claims my printer is not connected, which it is. this is very frustrating, so what’s-up?

Hey am I the only one who bought an Ender 3 Max Neo?