Sonic Pad Z-Offset

Hallo, ich habe einen Ender 5 S1 mit einem Sonic Pad. Nach einem Düsenwechsel und anschliessendem anpassen des Z-Offsets habe ich Probleme mit diesem. Das Z-Offset funktioniert nicht, ich muss immer 1,55 mm nachregulieren Woran kann das liegen?

Hi @3doli and welcome to the forums.

When you change the offset during a print to get it at the right level be sure to save the config once the print completes. Usually a message prompt should appear when the print completes asking you if you would like to save any offset or configuration changes. If you save the changes/config it should then remember the offset for all future prints :slight_smile:

Thank you for your answer. When my print is finished, the question whether I want to save the changes does not appear. Is there another option?

I have not had a chance to get hands on with the Sonic Pad as yet but you could try issuing the command M500 from the command line/console interface as this should instruct the Sonic Pad to save any configuration changes.

I don´t know where can i find the command line to set the M500.

I am not familiar with the Sonic Pad as I dont have one yet so am not sure. @jimandyen are you aware of any saving options on the sonic pad?

Not familiar enough yet. Sorry… :thinking:

1 Like

Hi - I have/had the same problem. After nozzle change I had to adjust the z-height by 0.4mm before every print.
In the past - 2 or 3 versions before Sonic Pad asked to save that changes at the end of the print - but not anymore.
I tried some probe-calibrate command, but that was not satisfying - manual procedure and the result was not as good as before.
But - answer to origin user - if you use browser with Fluid desktop (just enter the Sonic Pads IP in a browser) then there is a “save” button, where you can adjust the z-offset (AFTER the print has finished!).
Also there is a “save config and restart” in the top right corner of the page.
(Du kannst gerne Deutsch nachfragen :wink: - das kann ich besser wie das holprige Englisch)


Hi Peter, danke für Deine Unterstützung. Ich weiß nicht warum, aber es ist nach dem Druck nie die Frage nach dem Speichern des z Versatzes gefragt worden. Irgendwann war es dann doch so und siehe da, das Problem war behoben. Seitdem läuft alles wie es soll.