Unable to modify starting G code

I have been doing everything I can think of to Modify my Starting G code, with no luck. My computer took a major dump and had to start from scratch. I have I micro swiss direct drive, and a EZABL attatched to an ender3. was working fine but now it doesnt see the EZABL so my auto bed leveling doesnt work.

Can somebody explain why when I go to the mange printers pick the printer, I get to the screen where I can see the start g code I can erase whats there but it wont accept any input.

Thanks in Advance

Hi @Medic_Mike and welcome to the forums.

Depending on which slicer you are using you may have to make the adjustments after adding the printer to the slicer. Once the printer is added you should be able to edit the printer configuration within the slicer allowing you to adjust the start and end gcode commands.

I am using Creality Slicer. The printer is selected and I am trying to make changes to the profile. I see No where to put in the Z and Y offsets for the EZABLE and wont allow input into the Start Gode. I have the Ender 3 printer picked and I am assuming because it didnt come with Bed Leveling, this slicer doesn’t want to add it.
Seems like the software programmer should have an editor made that would allow you to edit the G code and save it independent of the printer. It’s your printer if you edit in a big BOZO then you only have yourself to blame.

Thanks for the input as you are very correct about adding the printer.


Yep when it comes to Creality Slicer you usually have to add the printer first then once added select Settings > Printer > Manage Printers. Then ensure the printer is selected on the left panel and select Machine Settings, you will then be able to amend the start and end gcode to your preference.