Updated sonic pad now fails to print from usb stick Ender-5 S1

Hello everyone,
This is my first post, hoping someone can help out.

My Ender-5 S1 with the Sonic pad has been working great. Last night I turned it on to print something and there was an update available on the Sonic pad. I did the update everything went fine. I loaded a file in the Creality slicer and sliced it as I always have. Put the sliced file on the same USB stick I have always used. Went to print, and it loaded and showed the image of the item to print, hit the print button, and nothing. Rebooted everything twice same thing. The other thing was when I added the Sonic pad when I bought the printer, the original screen on the printer was always dark. Now after the Sonic update the screen on the printer comes on and says calibrating. Any help would be great

Hi @F1200guy and welcome to the forums.

It sounds like something has glitched out somewhere, I would recommend reflashing the klipper firmware generated by the Sonic Pad to your printer to ensure the firmware is operating as it should. I have recently received the update and my printer screen remains dark.

Thank you very much for the response. How do I reflash the Klipper firmware to to printer? I did it a year ago when I bought the printer and Sonic pad together. I have no idea how I did it now. The screen on the printer always stayed dark until I did the update. Thank you again! Craig

In theory you should be able to pick the printer on the Sonic Pad to initiate the firmware install for the printer.

I have just checked the manual for the Sonic Pad and it looks like page 9 section 2.7 on-wards should cover the process for updating/installing the firmware.

Here is a link to the manual if you need it…
Sonic Pad Downloads

Hello, I did the reflash and still get the same thing. I slice the file and download it to a USB memory stick. Put the memory stick in the sonic pad open the USB stick load the print. the picture of the part comes up like it always did. Press the print tab it says loading for about 2 seconds and that’s it, printing doesn’t start. I have probably 20 sliced files that are on the USB stick that before I did the update loaded and printed fine. Now only 1 of the files will load and initiate printing. This is very frustrating. I have a bunch of stuff to print. Hopefully, you have some ideas.

I have been seeing several reports about issues with printing from USB so I get the feeling the issue might be in the firmware itself. I will keep monitoring the situation and if I come across a fix I will certainly let you know. For now I would upload the files to the pad via the web interface and print from there.

I too have the same problem, cannot print on Ender 5 S1 from the Sonic Pad. My print environment has not changed from when it worked perfectly. I have been dealing with this for over a month…very frustrating. The printer does just fine without the pad attached, but that is WAY clunky. I have restored the pad to factory and/or restarted Klipper more times than I can count, have flashed firmware 3 times on both the printer and the pad, ran the self-test (30 minutes!). Each time, at the end the printer self test says that everything checked out, printer is ready to go. explore, and the like. But when I plug in a USB drive and try to print the Sonic screen shows “loading”, then just “blinks” and the “PRINT” button lights up again…then nothing. I have tried to print both new jobs, and jobs that have printed perfectly in the past from the same g-code. Thinking maybe it slicer was at fault I tried two other slicers. NO GO. I’m thinking firmware issue. Whatever it is, can we get this fixed ASAP?

Have any of you tried printing my LAN or WiFi just to check it’s not a USB issue? My Sonic Pad is on LAN and no file issues at all. Blank screens, but that’s because the pad has taken over proceedings.