Using Octoprint on a Raspberry Pi 4 with an Ender 3 printer

I have controlled my Ender 3 using Octoprint running on an old Raspberry Pi B. I have recently upgraded to a Raspberry Pi Model 4B and have uploaded the Octopi-specific OS currently included in the Raspberry Pi Imager to the SD card running this Raspberry Pi. I have followed the process described described in “How to Set Up OctoPrint For Ender 3, CR-10, and Other Creality 3D Printers — Creality Experts” but so far without success. Has anybody succeeded in using Octoprint with a Raspberry Pi 4B as I have described above?

Hi Mickf
I run Octoprint on a Pi 4 without issues. The setup procedure I used is available on Youtube and works without issues providing you follow each step EXACTLY!
Here is a link to a procedure I used.
Hope this works for you.
Cheers, Spacetrakker

1 Like

Thank you for your response, JohnH. I feel sure this is the procedure I have been trying but this morning it worked !!! I am not one to look a gift horse in the mouth so shall just be grateful for a working system (once I have found out why I can’t drag and drop files any more!)

Cheers anyway

Haven’t yet solved the absence of “drag and drop” which I had before but can still upload files via the “Upload” button. Anyone else had the same problem ? My Octoprint version is 1.10.0.