Z extruder wrong direction / no Extruder movement

Recently I upgraded to direct drive extrusion for better quality prints. Afterwards the extruder won’t step forward or backward at all. I have pulled the cable out and tested it to another axis and said axis works so the cable is fine. I have tried to hook the stepper I took off from the upgrade and still no motion.
I also have a problem with the Z axis running the wrong direction for some reason, auto home causes it to go up instead of down trying to find the limit switch, followed by a no stopping point error.
I am wondering if this might be the sign of a bad board.

Hi @gbennett1425 and welcome to the forums.

I would recommend reaching out to support with your findings as they may be able to either offer a solution via firmware or a replacement part. It definitely sounds like something is either connected incorrectly or that the board has a malfunction.

Also Here’s a video of the issue https://youtu.be/A0GuaiQOXio?si=2KoO7zBbFKc-3FRD

Ok it looks like you may have cables plugged into the wrong ports. Adjusting the X axis should be making the printhead move from side to side not raising or lowering the gantry. I am guessing this might be that you have wired it up this way to show the motor is working??

Have you installed firmware recently and if so did you check that you used the correct firmware? There are often 2 variants of firmware for some of the ender 3 models so wanted to check with you.

I haven’t upgraded the firmware recently. I will double-check the cables, but I do believe I was testing them.

Hope you manage to find the issue and resolve it. If all else fails you could always try a firmware reinstall to ensure nothing in the firmware has corrupted.