Z-offset changing on CR-10 V3 w BLTouch

Hi Everyone, I pulled my CR-10 V3 printer out for the first time in a while and I am having a problem that has me stumped. I can’t get a good first layer. I have searched the interwebs and can’t find a solution. Here is what is going on:

I have run a M48 - Probe Repeatability Test multiple times. Standard deviation is around .002 which I think should be OK.

I have done this 15 times, 15 differnt ways, but here is the basics (short version)

  1. Level my gantry

  2. Initialize Eprom

  3. Set my z-offset using the z-offset wizard

  4. Store settings

  5. Tram Bed to within 0.01

  6. Adjust my z-offset. Offset = 0. 93

  7. Store settings

Sometimes now I level the bed and readjust z, but it doesn’t make a deference.

Here is the issue. Now when i try to print, my z-offset is no longer correct. When i check my z-offset, it still says 0.93, but needs to be adjusted to 0.97. Now i try to print again, and it still won’t print. Check my z-offset and it says 0.97, but needs to be adjusted to 1.02.

I thought it might be a problem originating from my slicer software, or Octoprint, but I can recreate it without even doing a print.

  1. move X/Y to 100/100 (same place each time for repeatability),

  2. adjust my z-offset to get just the right amount of squeeze on a piece of paper

  3. Store settings (or don’t, just for fun)

  4. auto-home

  5. check Z-offset

It is different every time I autohome. Here were the last few: 0.93, 0.97, 0.90, 0.94, 0.97, 0.90, 0.93, 0.97

I have also tried reverting to the firmware that came with the machine and still it doesn’t work.

Please help!

Hi @Mixmasta and welcome to the forums!

Sorry to hear you are having issues with the printer, it almost sounds like the printer is ignoring the initial Z height setting. I would recommend running through the following video to see if there is something that they show that may help you resolve the offset issue.

Install BLTouch on CR-10 V3

Good luck and hope you manage to get it working properly.

Hi! Thanks for all the Reply. I tried everything from here and from other forums, with no luck, but I did learn lots from the efforts and will be a better printer for it. In frustration, I ended up switching back to the stock firmware. Then I switched back to V2.1.2M_NIC and now I can’t seem to recreate the problem.

Hopefully it stays fixed!

1 Like

You’re very welcome @Mixmasta, glad to hear that the printer is behaving itself now and hopefully it stays that way for you :slight_smile: