10w Laser Module for Ender3


Got this laser module for Christmas and I cannot get it to work. It is connected correctly but LightBurn keeps throwing connection errors. I have tried several different USB cables and I keep getting the same error.

It starts up, makes a small mark on the wood and then stops and says it has lost the connection.

I tried downloading LaserGRBL and it worked better, except the Y axis didn’t move and the laser was focused on the metal of the printer. I pulled the bed out and moved the test piece to where the laser would be and it cut a deep line (was only trying to engrave) and stopped.

Any suggestions on how to get this thing working before I box it up and send it back?

Hey @JSchell
Welcome to the Creality Forum Creality
Thank you for joining…!

Have you updated the firmware for this module…?

How to Firmware update for laser module


Thanks for the info, however I have the Ender3 Pro not the S1, so my control unit is not the display like in the video. It is the old rotary button type.

Any other suggestions?