Bricked Ender3 v2 after SonicPad update

Hello there,
I haven’t had my Ender 3 V2 out for a while. It was configured to work with a sonic pad. I might have tried to print a file that was sliced for a normal Ender 3 without sonic pad. During printing I got a parsing error. Then, the sonic pad as well as a direct connection to the PC didn’t show any connection. The printer doesn’t do anything when I switch it on and off. I updated the sonic pad to the newest version successfully. Still nothing.

  • Trying to factory reset / update the Ender 3 V2 (with BLT and filament runout sensor). What is the correct firmware to use, how do I update? Do I reconnect the screen? I’m clueless.
  • Can I reflash using Arduino/ISP etc? I don’t have the flasher described on the website, do I need it?

EDIT: I’ve got it flashed now and it’s printing somewhat. But it always gives me an out of bounds error in the beginning. I can resume the print, but it will turn the temp down…

Hi @Ender3 and welcome to the forums.

To flash the firmware you would usually download the firmware files from the printer download page, extract the archive and place the firmware file on an SD card formatted as FAT32 with 4096 allocation units. Then insert the card into the printer and power on to flash the firmware.

There are often muliple firmwares available for some boards so its always best to check which version board your printer has and also which chip you have on board, it will either be an STM chip or GD chip.

1 Like

Thank you, that did work apparently after all. It just didn’t look like it because it didn’t do anything or react to anything or showed up in the serial. However, just when I wanted to give up it showed up again and now it’s printing fine. I think I just was’t patient enough.

I used the GD-Ender-3 V2-Marlin2.0.8.2-HW-V4.2.2-SW-V1.0.7_E_N_BLTouch firmware. To fix the out of bounds error I just configured a 220x220 build volume instead of the 235x235 that’s given in the Sonic Pad manual for the Ender3 V2. (The Ender 3V2 is configured to run with a smaller build volume from the factory if it comes with the clips, to avoid running into those, but the actual build volume is larger, and that’s what the manual for the Sonic Pad tells you to configure, but it only works if the printer knows about it. Did I get this right?)
I know I can probably also fix it by changing settings on the printer itself, but that’s a project for later.

The only problem I still have is that prints always start without heated bed. I have to manually change the setting on the sonic pad AFTER the print has started, which is a nuisance. The printer profile I use in CURA does specify the correct build plate temp.

Glad to hear it all worked out in the end :slight_smile:

Yep thats correct, quite often most people will swap out the stock bed for a PEI magnetic sheet which will allow you to use the larger area. If you have the bed clips then yes you would definitely want to change it to 220x220.

Double check your Start Gcode as you might find the variables for the bed and hotend temp are missing. Ideally you will want a line of code such as the following in your start gcode…
START_PRINT EXTRUDER_TEMP={first_layer_temperature[initial_extruder]} BED_TEMP={first_layer_bed_temperature[initial_extruder]}