Creality Print 5 showing no printers

I’ve just downloaded CP 5.x from the GitHub repository, MacOS version, and when I run it and am asked to select a printer, the list is empty. I cannot dismiss that dialog at all so I have to Force Quit the application.
On restarting it, I’m prompted to load a temporary file because it quit unexpectedly and I’m then at the main screen. There doesn’t seem a way to Add a Printer from the interface. I can quit CP normally. If I restart, then I’m back to the empty Add a Printer dialog and have to Force Quit again.
How do I get my K1 Max into that list of printers?

I’m running this on a M3 MacBook if that matters.

Hello @AndyJ …! :wave:

Welcome to the Creality Forum…! Creality

Look at the list on the link here and maybe see what version you have. It might be a good idea to try an older version just to see if the K1 Max shows up…

I don’t use Mac OS so basically guessing here to try and help… :thinking:

K1 Max Downloads

It would seem that downloading and installing V5.0.2 rather than the latest V5.0.3 is the way to go. K1 Max shows up then.

Not sure I dare upgrade it to V5.0.3 now though…EDIT: I dared and, because the download is self-contained (i.e. it doesn’t seem to pick up settings from previous versions), it doesn’t work and shows an empty printer list. There’s something wrong with the V5.0.3 release on GitHub that the devs need to get it sorted out.

I agree. The latest versions can still have bugs to work out…
I run and on the PC together until V5 is smoothed out… :crossed_fingers:

Are you saying the K1 Max now shows up and what did you have to do to get it to show…? (different versions…?)

Yes - see my response above.

1 Like