E3v3 SE not registering cr touch homing

Somehow, the printer doesn’t register the cr-touch giving a signal at all. I’ve tried to use a new cr-touch, checking the mainboard for loose connections, but not checking if the cable from the probe to the Sprite breakout board has anything wrong with it ( I have no spares and I don’t want to risk that) and reflashing the firmware, although I don’t really know if that would do anything. Any suggestions?

I would recommend trying to update the firmware to see if that resolves the issue with the printer. If all else fails and it still misbehaves I would recommend reaching out the support team who will be happy to help. You can contact them using the methods listed here:

Creality Support Contact Routes

The firmware was reflashed, as said before. Thanks for telling me about the support team!

1 Like

You’re welcome. I wasn’t sure if you had actually done a firmware update where you said you weren’t sure if that would do anything :slight_smile:

Has precisely the same issue.
Tried to re-flash firmware 1.0.6, restore to 1.0.4, again to 1.0.6, several times - no changes.

Changed cr-touch to new one - no changes.

Searched for some solutions of this issue, only saw few videos with similar printer behavior, no one valuable advice, besides “contact support”.

In normal state printer changes from violet to blue on calibration, eject probe and red on touch, but here we have red blinking on touch (error signal) and retractable probe.

Perhaps there is some new information about this problem and the possibility of solving it?