Ender 3 v2 neo stucked on creality screen after firmware update

Hi everyone!

I recently tried to update the firmware of my ender 3 v2 neo but the screen is stucked on creality screen. I followed all the recomendations like sd format to 4096 allocation unit size, put only the .bin file in the root of the sd, rename the .bin to something like 123.bin and nothing is working

I doubled checked my motherboard (4.2.2) and used the files of creality official page.

https://www.creality.com/pages/download-ender-3-v2-neo

Also, I used another sd with the same result.

I hope you can help me! thank you :slight_smile:

Welcome to the Creality forums!

Sorry to hear your having issues with the printer. I would recommend double checking that you are using the correct firmware, I notice that there are several versions for that printer depending on if you have bed leveling probe and/or a filament sensor. If you are sure that you have flashed the correct firmware and it still doesnt work I would suggest contacting Customer Support: cs@creality.com

Good luck and hope you get the printer running again soon!

Hi ramkp,

I solved this using version 1.1.7. Dont try to update the 9 lang. version, that seems utterly messed up to me.

Some humble tips before proceeding with these firmware updates :

  • Proceed in the same order from the video (machine first, display second)
  • If the printer firmware update fails, !DONT! follow up with the display update. Try again with another version.
  • Read the comments on the video page. There were some instructions that helps a bit.

Hi mediaklan,

The read me file that is embedded in the download from Creality lists the display flash first with the private, and firmware.zlib added to card after formatting with 4096. After flashing the screen first, then the 123456.bin file on the mainboard, my display is now permanently showing Creality home screen with some numbers that help navigate. If I get the procedure correct, it prints beautifully! But what frustration when it doesn’t print! I have tried starting over with the renamed 234567.bin file, then flash screen, but still stuck on home screen. Anyone know a solution? Mahalo!

Start over again from the beginning (1/machine+2/display). If that doesn’t work, try another firmware and start all over again. There’s not much we can do to help unfortunately - -
Note : the reason why I recommand to update the machine first is because if you fail to update the display first, you will end up with a messed up screen, making it a lot harder to try again.