Ender 3 V2 with CR Touch issues with Z-offset

Hi I have an Ender3 V2 with the CR Touch. The printer is printing well with very few prints failing I have just really annoying issue which is setting the Z-offset.

This is what I am doing (am I doing something wrong?).

  1. Switch printer on
  2. Pre-heat both nozzle and bed
  3. Home Z axis
  4. Slide a sheet of photo copy paper under the nozzle and use the micro-step function to adjust the height until it just grabs the paper. The Z-offset is -1.30
  5. Save
  6. Go to leveling menu and create a new mesh and save it.

I then do a test print and I can see that when it starts printing the nozzle is about 1mm above the bed so the filament is not being extruded onto the bed and so, of course, it does not adhere.

If I then go back and manually set the Z-offset to -1.90, save it, and redo the test print everything is fine. I get a good first layer which seems even and adheres well to the bed.

What I cannot understamd is why there is a difference between the -1.30 offset I get when I used the home Z-Axis function and the -1.90 offset I actually need to dial in to get a good print.

Am I missing something? Am I doing something wrong? Do I need a new CR Touch sensor? Any suggestions gratefully received.


What layer height are you printing at that may affect things as it’s squish. Remember due to the manufacturing process the thickness of the paper can be between, 0.5 and 0.1 that’s why it’s not done in thickness but is gsm

You want the nozzle at 0.00mm. It will rise up your layer height before it starts printing. So use the thinnest possible paper to get the most accurate results. Usually receipt paper is thinner than printer paper. If you gap it to .1mm and it rises up .12 on print, your first layer will be .25mm from the bed and not adhere well.

The paper is not a gap check, it’s just a guide to show you how close you are to 0.00mm home

You don’t need to get a new probe it’s fine. Get it close using the paper then baby step it down until it’s nice and that’s your setting to keep

Hope that’s clear

Hi, thanks for replying to my post. My problem is that the Z-offset I get when I home the z-axis is not the same as the z-offset I need to manually enter to get the first layer to adhere to the bed. It seems to be out by 0.6mm. If I visually inspect the hight of the nozzle after homing the Z-Axis and microstepping the nozzle to the dedired height, it is a faction of a mm above the bed, which is what I would expect. But as soon as I try and use that setting to print I can see that the nozzle is way highter that it should be causing the filament to be extruded into thin air!

It is really puzzling and I am at a complete loss to explain why this is happening. I am now wondering if it could be something wrong with the gcode file which is adding some sort of offset.

In all other respects the printer is fine and prints very reliably.

Check the slicer itself it has an offset option maybe you have something in that

The offset is always the offset as it’s the distance between the activation point in the probe and the nozzle ie. The activation point of the probe is 2.50 mm lower then the nozzle

That is a constant apart from nozzle wear and a new nozzle will change it