Ender 3 V3 SE CR-touch static red on startup

I just got my printer a couple days ago and was able to assemble it quickly and start printing.

It seemed fine until when I turned off my printer and then went to sleep, the next day when I turned it on in the morning the display was stuck on the bootup/creality art screen. I tried reinstalling the screen firmware and motherboard firmware at version 1.0.4 and it worked once, but then it didn’t boot again.

It took me around 3 days to figure out that everytime the CR touch was a static red, not flashing, the printer would not turn on. Is there any way to fix the CR touch or modify the screen or motherboard firmware to bypass this? Thanks.

The latest firmware is .6 try that.

Tried that already, nothing seems to work.

Is the pin slightly bent or dirty causing an issue in deploy. You could need a new probe

Reseat all connections might help.

1 Like

Good call. I had to replace the probes cable after I got it caught in the shroud when I had to replace the fan. Wish they had gone with a better size fan on it so can be replaced with something better

The hot end fan is rubbish, both my SE and KE squeal until they get warm. Best improvement to both printers is a better fan.