Ender 3v3 SE homing and firmware update issue

Hey guys,
I’m a tech teacher who maintains a lab with about 14 Ender 3 V2’s. All been great once I learned their ins and outs. Not claiming to be an expert but not my first rodeo either.

So this V3 SE has me puzzled. It’s got 2 issues- It was initially working normally for about a month or so until the following has happened.
First- The X axis travels in the opposite direction of the limit switch when homing, to the right, away from the limit switch bumper. It goes until it crashes. Manually clicking the limit switch does not stop the travel. I am not able to manually jog the machine around either, when I go to the move controls it just wants to go right into a home sequence.

Second issue - Now my first thought was update the firmware since its running v1.0.4. Downloaded the 1.0.6, formatted the Creality OEM SD card to FAT32 and 4096 allocation size. Updated the screen first successfully. Then inserted the motherboard SD card while the machine was off. Turn on and got the blue screen freeze with nothing happening. Let it sit for awhile with no progress. Turned off, changed the file name of the .bin file to “firmware.bin” and tried “firmware123.bin”. These attempts lead to printer just going straight into a select language and auto Z offset calibation sequence with no other options. It does this with or without an SD card in the slot. So it appears the machine is just ignoring the bin file altogether. It read print files no problem before I formatted it just won’t boot into the firmware update. I put the original file without changing the name back on the card and now it’s just acting like the card is not in there and going into that sequence again. None of which I can just let go and see what happens since it starts crashing into the right side of the frame as it’s doing it’s thing.

I reached out to customer support tonight, but in the meantime does anyone see anything I’m missing?

Try another SD card, they do go bad. Tried Factory Reset?

Thank you for the reply! I had tried about 6 different cards with the same result. I have not tried a factory reset yet- I’ll look that process up and give it a shot. By factory reset you mean there’s something other than just selecting the restore to factory settings option in the menu? That I did try

Anything of use in the reddit FAQ? https://www.reddit.com/r/Ender3V3SE/comments/18yqaar/read_this_first_faq_common_issues/

Thanks for sharing, I’ll be double checking this list tonight. Creality support asked me to make a video of the issues so I’ll be doing that as well. Maybe I’ll be surprised on their end!

I went through and no luck on any advice there :frowning:
I am currently stuck in limbo after updating the screen again to 1.0.6. I cannot go back to 0.4 without just ending up with a screen with some blank options. With 0.6 installed, I keep trying to install the update to the mainboard but it will still not recognize the bin file. I uploaded a video of this to show creality support. Will update if anything new develops.

Have you tried unplugging the x access just to see how far it’s able to progress where you might be able to gain access the printer’s info screen.

I looked at your video from start to finish; awhile back when I did the FW change from 04 to 06, it did identical boot steps as yours going to language followed by bed calibration; I was surprised how quick the new FW booted. So, I bet you have 06 installed but definitely some SNAFU stepper motor problem on the X axis.

Oh interesting - So that calibration is supposed to happen, good to know! And wow I would be shocked if the FW had loaded. I didn’t see it try even for a second.
But okay thats a good idea about unplugging the X motor to see if I can get to the end of sequence- thanks for the response! I will try when the house gets quiet tonight.

Forgot to mention to also look for a broken wire or connection on your x axis wiring harness.

Well you were right about 2 things! The firmware did actually load, just super fast like you said. And I unplugged the X and let the bed leveling do it’s thing. Menu popped up and firmware 1.0.6 in the info section. Unfortunately the X axis is still acting the same. Creailty told me this morning that they are sending a new motherboard. So hopefully that will get things straightened out. Will update when that comes in.

Well just to follow up with a resolution for anyone else who has this issue. Creality sent a new motherboard under warranty. Was a quick install using the creality YoutTube video and the printer is back to fully functional.

1 Like