Ender v1 Sprite All metal upgrade issue


I got the new Sprite all metal upgrade last week and installed the new firmware to my 4.2.7 board with a 235mm bed. Everything was fine but when I tried to do the marlin firmware it was grinding on the X axis.

So I reverted back to the 2.4.7 firmware (official) and got it printing again. I printed off something today with a z offset of -0.7 & it was perfect.

I then read that the grinding on the x axis was due to a bolt on the bottom of the new kit & that the new mount would alter the x axis. Now I could clearly see the new mount that hit the end stop, so I decided to take the mount off and have a look at the new bolt compared to the old bolt. There was no difference, so I put it back together, this is when I ran into huge problems.

After I had put it back together with nothing changed on the firmware and the z axis was still reading as -0.7 and the bed hadn’t moved, but when I was to print the nozzle was no where near the bed. I cancelled the print and rechecked the z offset and found it to be well over 5mm away from the bed :exploding_head:

Can anyone suggest what to do as this should NOT have changed at all, but somehow the firmware has completely messed up my settings within 10 minutes after being switched off.

Thank you for any advice.

Hi @Roy76 and welcome to the forums.

I would recommend checking that you have the correct firmware installed for the Printer and Sprite Extruder as the extruders have different configurations to the stock extruder.

You didnt mention which printer it was you are having the issue with?

Its in the title, Ender v1 with 2.4.7 Creality board.

I’ve managed to install the latest Marlin firmware today & got the printer homing perfectly now. After I’ve raised the bed I’m now -3.10mm on the Z-offset which should be workable.

I’m now waiting for a set of smaller bolts as the bolts that came with the Sprite upgrade kit were 30mm long which is hitting the X-axis bracket. The new bolts should fix the hitting of the bracket.

I’m just puzzled how its gone from -0.70mm with the bed to a -3.10mm with just removing the unit from the mount.

I did have the correct firmware from Creality downloads section for the printer, but it was just the z axis that has me puzzled.

Glad to hear you have the printer homing correctly now. I completely missed the mention of the printer in the title so I do apologise.

It is very puzzling that the z offset changed so much, I can only assume there was a large z compensation within the printer configuration to begin with.

I regards to the bolts being too long, I have seen some people turn the bolts around so they go in the other way to provide clearance. Not sure if this is an option on the Ender V1 or not?

No problem, yes I’ve seen that too with the bolts which is what I’ve done now and it’s VERY close to the heat block.

I’ve been able to do some test bed leveling prints now, but the z offset is now around -3mm.

I had to put the bed as low as it could go, then home the printer. Once this was done I lowered the nozzle down to 0 and raised the bed to the nozzle. I then saved the settings and did another home. Once this finished I did a z offset wizard and it was still off from the nozzle and altered it to -1mm until the bed was close to the nozzle. I thought perfect. Saved the settings once again and did an auto home again. I then went through the z offset wizard to confirm the settings and found it was still off by another 2mm. This is where I’m now found myself at -3mm.

It is very common to run a negative z offset. Hopefully with a little tweaking you will find the perfect settings and offset.