Ender3 V3 SE not completing levelling and won't read SD card

I built my V3 SE about a week ago and have been busy so havent started playing around with it until today. When I tried to do the levelling (originally when I built it and again recently) it move around for a bit and then just stops the process without showing the green levelling data at all. I can access this data through “Control” but all are set to 0.00. I was watching a video on how to set it up and feed the filament and did the Extrude operation as that video told me which seemed to run fine and then at the end let out some filament which sort of just piled up until it stopped. Anyways, i went to print a small piece that i CADed up and the printer orignally read the file fine. I then took the card out to add another file and now the file queue is completely empty. Not sure if i have somehow damaged the reader or what.
If anyones got answers that would be great

And the files are still showing when you put the card into a card reader to look at them on the PC?

Yea all the files are on the disk drive when i plug into my pc

Happened twice to me at the beginning, but a restart was enough to read again the SD card. If the issue persist I would suggest to upgrade the firmware to it’s latest if you already have it then try to connect a version of Octoprint to your machine via USB and then try to transfer a small file to the SD card using the web page. But seriously use a small file because since the transfer is done by CDC communication it is very slow.

If the transfer fails try to check the Octoprint terminal tab for errors.

About leveling with the lastest firmware you can edit the values so you can perform the manual level process with the paper sheet. And after completion you can go and select the “Store configuration” option. Then you can try another reboot and see if the values are still there.

Have you checked the printer voltage selection switch to ensure its in the correct position for your region? Quite often if the selection switch is not in the correct position the printer will reboot/shut down when it tried to heat up for the bed levelling procedure.