Firmware upgrade woes

I upgraded my ender 3 V2 from a 4.2.2 motherboard to a 4.2.7 this week. It was running the earliest version of the firmware available so I decided to upgrade.
I don’t have any upgrades to the hardware so I picked Ender-3 v2 4.2.7mainboard (32bit) → original firmware from the archive. I formatted my 2G SD card as fat 32 and 4096 blocks. I copied over the file Ender-3 V2-Marlin-2.0.1 - V1.0.1 - TMC2225-(对应V4.2.7主板).bin and renamed it to 123.bin (only thing on the card) inserted it then powered on the printer. I get a blue screen and nothing else. I’ve left it on for 20 minutes in hopes it would finish up but so far nothing. I’ve tried a couple different unique filename with the same result.

Any suggestions as to what else to try?

Hi @lsteensl and welcome to the forums!

I would recommend double checking to see if there is also a firmware file that you need to flash to the screen too. There is a small SD card slot on the screen itself and often when replacing or swapping out motherboards you tend to have to also flash the screen firmware along with the printer firmware.

Come to find out after all this time, I don’t even have a ender 3v2 its an ender PRO! I spent a lot of time on the creality website saying to myself, that doesn’t look like my printer, but that’s what amazon sold me.

Went to amazon, checked out my purchase from 3 years ago and I’m just now realizing what I have.

I just not downloaded the firmware for the Pro 4.2.7 motherboard (which I also just got from amazon) and it “just worked” So my final question is, how does the off the shelf mobo know if it’s shoved in a V2 or Pro? My only guess is the LCD is completely different, so it must be able to read the type of LCD and know from that.

Glad you managed to resolve the issue with the firmware.

It is likely that the hardware on each machine varies therefore indicating to the mainboard what hardware configuration/machine it is connected to.

1 Like