First layer and possible overextrusion with Ender 3 v3 KE

Hey all, this is my first post here so please bear with me if I miss anything, and feel free to let me know what I might need to include.

Recently I got my first printer, the Ender 3 v3 KE, and for the most part it has all been good.

I’m having two issues though, the first being poor first layers with the automatic calibrations, and the second is what seems to be overextrusion from what I have been able to find while looking things up. I’m looking for any advice on what could be the cause of these issues, and/or anything I might try in order to resolve these issues.

I am using Orca slicer and have used all of its built in calibration tools to try and calibrate for my filament. Initially I had these issues on only some prints using Hatchbox Black PLA, and have been having all the same issues using Elegoo Black Rapid PLA+ as well, but have only run one print with it so far.

Images/videos are prints done with the Elegoo filament.

First Layer Issue:

When printing the Benchy that comes with the printer everything is fine, but with the automatic bed leveling and z-offset done by the printer, as soon as I try one of my own prints, unless I modify the z-offset the first layers are very poor, causing the print to not adhere and thus fail.

I have done a few test prints of single layers (100mm x 100mm) and with the default calibrations and what I felt was happening was that the nozzle was too far from the bed, and the result is the image below. Other than the section that is solid in the top right corner leading down to the bottom right, everything that is lighter are individual strings and not actually connected in a cohesive layer.

This seemed to be confirmed when I set the z-offset to -0.1 (did the change directly on the printer, then removed it from the printer and made the change in Orca instead and had the same results) I got the below first later and this has been successful on all other prints I have run with this setting.

I then tried to run a full print bed first layer (220mm x 220mm) with the negative z-offset and got barely halfway through before it was too poor to continue. I do not have an image of this one, but near the front of the bed was especially bad with a lot of holes especially around the corners of the bed, and the print failed before it got to the back of the bed so I am unsure if the back of the bed has the same issue.

Generally I am happy to leave this setting and just make sure I slice my prints in the middle of the build plate, however, my question is that if the printer should be doing this all automatically, why would I have to go in and adjust again after? I confirmed that the bar holding the hotend is level when z is homed. Should I be trying to manually level the bed even though the machine does it manually?

Is there something I am missing that I should check/adjust on the printer to make my first layers better?

Overextrusion Issue:

For this issue I am not sure if it is truly overextrusion, but I don’t know enough to be sure. When trying to diagnose the issue myself I found this Reddit thread where OP was having the same issue I was and based on the tread this is overextrusion. Initially using the Hatchbox PLA I used the Max Flow rate calibration from Orca slicer and came up to 18 mm ³/s for the max volumetric flow, but this was the value I already had in the filament settings.

Below is the first print I have run using the Elegoo PLA after running the Orca calibrations as well, and I still have the same noise.

The Max volumetric flow for this print was also 18 as I wasn’t 100% sure with the results of the calibration test.

I am unsure if this is actually overextrusion though given the first issue with manually changing the z-offset. It sounds like the nozzle is scraping the print, and so could that be caused by the negative z-offset? When this issue was happening I went and manually raised the z-offset by 0.1 mm mid-print and it sounded better but did not completely fix the issue.

Given that it did not compeltely fix the issue but did make it better, could it be a combination of overextrusion and too negative of a z-offset

One thing I have yet to do that I did come across is to calculate the e-steps, but I am apprehensive to do this as I am not sure if this would solve the issue since I am unsure if this is actually overextrusion.

Would anyone have any other advice/knowledge that may lead me deeper into fixing these issues? Any help at all is greatly appreciated, thanks in advance!

Below are screenshots of my various Orca settings of both the printer and filament for reference if they are helpful. If any other settings may help feel free to let me know.

Been doing some more digging and have made a bit of progress.

Found a few videos by RCSchim on YouTube where his first layers were looking similar to mine on this video.

Following his next video, my firmware was already upgraded but I decided to also install Mainsail and connect my printer to Orca slicer directly. Previously I was importing my prints by going to my printers IP in my browser. Now with Mainsail installed (I followed this page to do so) I feel this may have been at least some of the problem.

After doing this I printed another full-bed sheet and got the below result. Still not amazing but at least it printed the full sheet.

I then realized I did not re-calibrate the printer, so redid the automatic calibrations from the printer itself and got the below result, which has very similar patterns.

I then checked the bed screws under the build plate based on the suggestion in the other forum post linked below and they were all roughly 1/4 turn loose. So I tightened them, cleared the bedmesh from the Mainsail UI and calibrated it from there and did another print, but this one did not go well at all, as seen below I had to stop it very early.

What also confused me even more though, is between the second and 3rd full sheets that I just printed I also tried to re-run the print that I was having issues with earlier as well, and this print has a perfect first layer from what I observed while it was printing, so it does not match the full sheet pattern that I was getting. Upon investigating further I believe I didn’t properly remove the -0.1 z-offset from the printer settings in Orca so this could very well be why this first layer looked better and I still ran into the scraping issue as mentioned below.

I was still running into the issue of the grinding noise and saw that this post came up after mine regarding the same issue, and apparently this seems to be very common among the KE lineup given I have seen 4 instances of this issue now. Below is a picture of this print after I stopped it, and at least in my opinion it does look like the nozzle or something is squishing the horizontal infill lines.

Based on the suggestions in the other thread I believe I already have z-hop enabled but tried with the gyroid infill at 10% instead of cubic at 20% (fixed the z-offset that I forgot about as mentioned above as well). The first layer did not look as good this time, with the left side of the print looking nice and solid and connected but the right did not, and near the top it looked poor as well. I tried to capture it as below but since I am printing black filament on a black bed it is hard to pick up.

The second layer as well wasn’t great either as now where the first layer looked good the nozzle appeared to be too low and scraping slightly.

It is currently still printing, but so far switching to gyroid infill seems to have solved the nozzle scraping.

I would still like to try and determine why I am having such issues with initial layers as well as the cubit infill, so if anyone has any additional insight as to what may be going wrong or what I could check/try, I would appreciate it!

What does your bed level look like? It should be good if it is within a 2mm window, the software should cope. If you want to chase it to be totally level then kapton or aluminium tape on the magnetic plate or silicone spacers instead of the black spacers (I think they are Delrin). You could even machine new spacers from Delrin if you want. If I could be bothered I could machine new spacers, but I have a lathe and a mill to use so beyond most people. Could print new spacers?

I had a scraping problem and solved it the same way you did. Gyroid infill. As you mentioned there is z-hop and maybe you need to tune value?

Why do you set z-offset in orca? I’ve never tried it.

In my case, I had to bring the z-offset closer to the table by 0.05 to make the first layer look bearable and still the edge of the table is not perfect. For me it’s just one click on the touchpad and sometimes the flat surface of print is rarely scratched by the nozzle, leaving a delicate line. When I raise z-offset the first layer for petg looks not to much squished for me.

If you make changes to the offset, you can check the saved value that the printer uses in printer.cfg. In my case, this value is not refreshed immediately on the touchpad after calibration and I was pulling my hair out.

Remember that in webgui you have greater precision in tuning z-offset than on the touchpad. Be sure that you save new setting.

You can try to do what Bonfireman mentioned. Leveling shims.

I haven’t done it yet, but there is one more option:

Klipper will do auto level under the print only.

I won’t be of much help because this is my first printer for a few weeks, but I wanted to draw your attention to checking the offset value in printer.cfg. I don’t know if orca change it “on the fly” when you send gcode to print.

This is what I have from the Mainsail UI for my bed level which if I understand it right looks like the range is 1.8mm.

I’ve also been having stringing issues lately so going to try disabling z-hop to see if this resolves that now that the gyroid infill seems to have fixed the scraping.

I tried setting the z-offset in Orca just so that I didn’t have to keep going over to my printer and changing it, no real reason tbh. I’ll dig into bed levelling some more and see if I can manually fix this to help the automation along some, thank you both for the suggestions!

I’ll show you my bed after printing and using shims.

And i forgot to tell you about “better” flow rate test. You can try it. It worked for me and calibrating my esun PETG after printing out half of spool not to good prints.

It can be tricky because for KE you need to change print settings by hand. Just note them or open two instances of orca and move settings between them.

Thank you both for the suggestions, it really is appreciated!

I’ve printed a few shims and my bed is indeed far more level now. Still not perfect but I’ll keep tinkering, and the gyroid infill has solved the nozzle issue as well, so I should be good to go from here.

Thanks again!