I cannot connect the Ender 3 v2 3D Printer to my computer

Hello, I tried to connect my 3D printer to the PC but it still doesn’t work. I tried installing the drivers, putting an isolator on the first from the right USB pin, Another Slicer, but nothing works. Could someone explain to me why it doesn’t work? Thank you.

Hey @Thomas141 ,
Welcome to the Creality Community,

Did you ever get your printer to connect. ???

Nope. Haven’t connected it at all yet.

I’m not familiar with that printer but maybe try a different cable…? Just a thought… :thinking:

Already thought of that, i’m currently finding a data-only USB A to micro USB cable (also i used an cable extender, would that be an issue too?)

If the cable is too long it could be a problem. I’m not sure how long the cable can be before the data can be used… :confused:

The Ender 3 V2 does not operate as a USB printer as such, I am getting the impression that you are trying to use the printer in a similar way to a normal printer, this is not possible as computers do not know how to communicate or control a 3D printer. You will need to copy your files to an SD card and insert the card into the printer.

If you wish to use the USB side of things or make your printer accessible remotely then you would have to look into a Raspberry Pi running Octoprint.

btw what pi would you reccomend me to use?

I have successfully controlled my ender 3 v2 from my Surface laptop via Cura 5.5. I did notice that one USB port on my USB hub wouldnt work whilst another was just fine. Seemed like the computer was only happy to assign the pseudu-COM port to one of the hardware sockets. Suggestion: try another USB port.

Most should work fine but personally I used a 2GB Pi 4b.

Alr, will try that too but i have little hope of it working.

buy a creality box 2 around £39, works great then you can control your printer with your PC and phone, takes about 5 mins to get it working, i have 3 boxes, no more swapping SD cards,

Connect it via Ethernet. Plug into the printer and the other end onto router hub. Then load what software your going to use to control it

Ender 3 V2 does not have an ethernet port unfortunately.

My bad, forgot I’ve been using a raspberry pi. Sorry about that


1 Like