Issues with Creality Print AppImage on Ubuntu 22.04 - Seeking Assistance!

Hello Creality Community,

I recently acquired a Creality K1 Max printer and have been trying to use the Creality Print slicing program provided by Creality. I downloaded the latest version, Creality_Print-v4.3.7.6627-x86_64-Release.AppImage, released on September 27, 2023. However, I’ve encountered an issue while using it on my Linux Ubuntu 22.04 system.

Whenever I click on the “Slice” button, the screen just flashes, and the slicing process doesn’t start. It’s worth noting that there’s no error message displayed in the console where I run the AppImage. Interestingly, the same program works flawlessly on a Windows machine, confirming that the procedure I follow isn’t the issue. This seems to be a bug specific to the Linux Ubuntu 22.04 version.

Has anyone else faced a similar issue? Is there any chance Creality will address this bug in the near future?

I’ve tried using Ultimaker Cura as an alternative, but I couldn’t find a reliable profile for the K1 Max. Furthermore, the profiles I did come across don’t seem optimized for the K1 Max’s artificial intelligence features for the first layer of the laser lidar. It seems I might have to resort to using a Windows system for my printing needs, which is inconvenient as I don’t have Windows installed on my office computer. Currently, the only Windows machine I have access to is my daughter’s laptop.

Any guidance, workarounds, or updates from the Creality team would be highly appreciated. Thank you in advance for your assistance.

Best regards,
Gustavo Aragão - Brazil

1 Like


This seems like the problem I reported here. Problem has been fixed since then, however the version (v4.3.7.6631) has not been published yet. Maybe you can ask Creality support to send it to you,


I have exactly the same problem here.

Using ubuntu 22.04. I tried Creality print on multiple linux distributions and all of them with the same result.

Just a flash when I click on slice button.
Also tried other slicers for linux, but none of then have a good k1max profile :frowning:


Here is the link I was provided with, it seems to be still working.

Really surprised it has not been published yet.


Hi Juan,
Thank you for the link ! :slight_smile:
bu the link appears to be expired. Can you make a link under wetransfer? It’s free and I believe without registration

You’re right. The entry appears but I didn’t notice the message telling about it being expired. Here you have the WeTransfer Link.


1 Like

Thank you very much Juan!

This build just works!!!
Finally I can stop dual booting. :grinning:


Really surprised it is not published yet, after more than two months. Creality support team were really cooperative when I reported my case, until the solution was found. I would say one of the best tech supports I have ever experienced. It makes no sense to keep Linux users away from this version.


Can you please re-upload the file?

Latest version of the slicer can be grabbed from here…

Creality Print V4.3.8


Thank you very much

1 Like