K1 Camera Not Connecting

Hello everyone, I’m new to the group.

I am having trouble with my New AI K1 Camera not connecting. I have confirmed wire is fully inserted. I also confirmed Cable is inserted at the base of the unit next to the motherboard. When I log into the IP address, I see a camera not connected message.

I ended up purchasing another K1 camera thinking there was something wrong with the camera itself.


Any thoughts?

Hello @Chris1…! :wave:

Welcome to the Creality Forum…! Creality

When you run the K1 does the camera icon show up in the printer’s screen…?

If you run Creality Print does the camera show anything in the “Device” tab…?

If you run Creality Print does the camera show anything in the “Device” tab…?

I actually opened up creality print and there is no device listed. I attached a picture.

I’ll manually will add the camera to the device tab.

When you run the K1 does the camera icon show up in the printer’s screen…? I don’t understand this? I’ve never noticed anything.

I added the K1 printer. It found the printer. Camera not connected.

Did you try the “+ Scan Add” option…?

All your printers should show up if they are online…

Yes, I found the printer it is hooked up to my network. What should I do now?

A picture of the K1 printer linked to Creality Print.

Just to check if the cam is connected press the “Details” tab.

If you don’t see the camera there could be a bad camera, bad connection or something just needs to reboot…

I clicked on the details tab and it states rejected our connection request

I ended up purchasing two different cameras neither one would connect.
I allowed Creality though my firewall settings too. Thinking that may be the issue.

Not sure but something to check maybe virus program or windows security options…
I got that error message also in the past and after printer reboot or PC it started working…
Very confusing…
Make sure that cam is connected right. It’s kind of a tight spot to work in. I wonder if the other end at the motherboard is plugged in…???

I will confirm windows security later today.

I flipped the printer bed over I was hoping someone could point out exactly which connection is my printer cable. I tried wiggling the cable to see if i can feel or see it move but its so tight.

I have 1 connections with no wire in it. Please see the pictures.

Check this connection. It’s for the camera… :arrow_heading_down:



I wanted to reach out to you and let everyone know that the camera for the K1 is now working.

What it ended up being i had an older version of firmware. I updated it to the most recent version CR4CU220812S11_ota_img_V1.3.3.5.img and now it works great.

Please see the attached photo. I appreciate your help. I feel like we don’t take the time to update everyone once we figure out what the fix is.

Thank you for helping me. Because I emailed Creality, CSsupport and they did nothing to help me except ask for proof of purchase and tell me it might be a bad cable.

Thank You,

Great. Thank you for sharing that and maybe your experience will help someone else…

Glad it’s working. :+1: Have fun.

Let us know how it’s printing if you have a chance…! :grinning:

I have a 4 hour print going its at 10%

Using PETG

1 Like