K1C key:2529 Leveling sensor chip

2 crashes today
on the second print got the key error… put 2 Dimple holes in my Bed releveling the bed


Is my Printer fubar ?

This same thing just happened to me on my K1C. Prior to the bed crashing into the nozzle the bed went all the way down to the bottom of the chamber and then all the way back up which it never does that full movement before printing. The only thing I did differently when the problem occurred was I unchecked the calibration option before sending the print job over LAN. I figured it was safe to do that because I had just printed something successfully minutes before.

I tried after that and it crashed again into the nozzle making a second indent just like you showed. I turned the machine off at the switch and then back on and ran a self-leveling check. After the self-leveling check completed I sent the print job again but I checked the calibration check box, and it seems to have worked fine this time.

So I’m not sure what happened but it seems to be working now. One thing is for sure, if I ever see the bed going all the way down to the bottom of the chamber again I’m going to immediately turn the machine off and run a self-check again. I’m hoping this is just something simple as part of a recent update and hopefully Creality can fix it.

1 Like

I sent info to Creality and they said if it happens again they will send a me a replacement board … the bed went so hard the belt was skipping hope the rail didn’t get bent … time will tell … if I get bad print …

Interesting. I guess it’s good to hear they are responsive and willing to help out. I may message them as well just to get that conversation started. Since I had the problem at first, it has happened again. When it happened the second time I decided to unscrew the heated bed surface and I disconnected all five cables (for the levelling sensors and the main cable going out) from the PCB and reconnected them. Ever since I disconnected and reconnected the cables the 2529 error has not yet come back. I have done several prints including a few in a row without restarting the machine. So we will see how it goes over time, but I’m wondering if it was simply a loose connection.

I noticed there was some yellow colored adhesive on each of the white plastic cable connectors. It was a little bit sticky but wiggling and pulling on the connectors was enough to break them free and disconnect them. So I wonder if the glue was holding them in place but not in a good way.

I’ve just bought ender 3v3 and having same error code not even 1 print

I just wanted to post an update on my situation since it has been a little over a week. I have printed several things on the K1C without an issue and I have not seen the error message 2529 return since after unscrewing and lifting the bed, and disconnecting and reconnecting all five of the white connectors underneath on the PCB for the sensor cables and the main cable.

I suppose it’s hard to say what exactly happened to cause the error initially, but I’m starting to believe that one of the connections was just loose. I noticed the error occurred after returning from vacation. So I’m wondering if maybe just a little bit of corrosion happened during that down time? The room where the printer is located is a bit warm but it is a dry climate here. Who knows? But, if anyone else is having this issue it is easy enough to disconnect and reconnect those wires under there, it doesn’t cost any money to do, and it might just fix your printer, too!

I haven’t got a bad print since… I got another Email from Creality assuring me that I am still covered and the case is closed and if I have any problems is to file a report …


1.Regarding the key 2529 issue,

Please move the machine to a non-vibrating environment and make sure your hands do not touch the hot bed when resetting to zero to check if this error code still appears


I built a Solid table from a old Office Desk … even braced it to the wall no movement at all … lol

Update Got the the ERROR Key:2529 Again
Made another hole … lol

Oh man, that’s frustrating! Hope you figure it out! Maybe it’d be worth unplugging and plugging back in those cables under the bed surface. That seemed to work for me.