Leveling sensor chip abnormality, sensor damage or environmental impact

I’ve been getting an error constantly now. I dont know what to do.

Hello @Devinhamby ,

Welcome to the Creality Forum. Hopefully someone can help with this.

Is that a K1 Max. ??

Did you just download the latest firmware update… ?

If you can go through the menu try setting the machine back to factory defaults (uncheck all the cleanup options)

Send pics and purchase info to cs@creality.com

Hello Jim,
I am also getting this same error message. As well as several others. This is on my new K1 Max. Yes, this error message showed up right after I updated the firmware to from whatever was on the machine when I got it a week ago.

I suspect there is an actual hardware problem and here is why.

With the original firmware the printer has only managed to successfully print one item. The pre sliced test cube. That item did not have a perfect first layer but it worked. I had enabled all the Camera AI functions for that print. Everything else I have attempted to print since then has failed. The first layer is just not level to the build plate.

I attempted to run the Auto Leveling Self Check a few times and it was digging deep scratches into my build plate. Lucky for me I flipped it upside down so only the paint was scratched.

I followed the steps to Manually level or Tram the Build plate. Opened the bottom of the printer took off the belt. Bolted the Z mounts to the bottom of the printer. Put the belts back etc. But it would still dig into and scratch the build plate after that.

Then I attempted to upgrade the firmware to Now, it fails to even start the Auto Level Self Check. Instead, it gives me one of the error Key:2521 messages.

I rolled back to Firmware version The error messages stopped but I still couldn’t get the machine to pass an Auto Level Self Check. It would keep digging and scratching into the build plate. That is not good. Then I upgraded to again and am back to where I started.

I did go into settings used a factory Reset with all the boxes unchecked. That didn’t do anything to fix the problem.

Here is what I can do to repeat the different errors I am getting. Again, this is a K1 MAX running firmware.

I power off the printer. Wait 10 seconds then power it back on.
Using the touch screen I Click into movement and click to Home Z
The Machine will home X and Y first. Then it will lower the Z by about 5 mm and nine times out of 10 it will give me this error message. “Error key:25``,Leveling Sensor Chip Anomaly or Sensor Damage.”

On the rare occasion that it doesn’t give me that error message right then it will wiggle the build plate up and down and bit then move up toward the nozzle. (It gives me hope.) Once it comes into contact with the nozzle it lowers by 5 mm and then gives me the other error messages. “Error Key:2522, Level Sensor Data Transmission Anomaly.”

If I attempt to run the Self Check it will give me one of the two errors as well.

Oh, I forgot to mention. At once point I took the Heater off the Z axes as well. I moved the spaces and everything so it wasn’t putting and weight or pressure on the 4 sensors. And it gave me the same error message when I tried to home the z axes.

Hello @Mordiev Welcome to the forum with your K1Max.
Sorry it’s been giving you headaches… :imp:

Unfortunately I think you are right it’s most likely hardware related. Can you exchange it or return it…?
It would be less headache than trying to replace all the sensors and boards etc…

When I first got mine it wouldn’t calibrate and just dug the nozzle into the build plate a few times. I watched it and knew when it was about to mess up so I could turn it off. It hasn’t done that now for quite awhile… Creality was nice enough to send me the leveling sensors that go under the plate but I haven’t got up the courage to install them yet…


Hi Jim,
Thanks for the reply. Sadly, I can’t take it back. I didn’t get it through the normal retail channels. It was auctioned off because the glass door was shattered while still in the box. It took me over an hour to clean out all the shattered glass. I ordered a replacement door and thought I would be good to go. No other visible damage, dents or scratches. It still has that “new printer” smell.

Ok. Well, I will contact Support and see how much they want to charge me to get this thing working.

Hey @jimandyen,
Do you know if it is possible to see the Bed level sensor readings? I assume with the rooted firmware that it should be possible.

I haven’t rooted mine but that’s a thought. You might be able to…

You should be able to get the bed level readings by visiting the WebUI of the printer using a web browser. Punch the IP address of your printer into a web browser and you should see in the bottom right hand corner a illustration showing your bed level.

Also as a side note, if you are in the US or a country that has a 110/115v mains supply ensure you have flicked the voltage selection switch to the correct position. It is recessed in on one side of the printer.

This is from the WebUI of my K1 Max. What is the scale to the right…? Or should I ask how do I read this…??

Hi Jim,
There are several comments on the web saying how misleading this presentation of the data is. Creality has stated that as long as you are within 3mm from the highest point to the lowest point then you are ok. In this case you have a high of +1.35 mm and a low of -0.3 for a total difference of 1.65 mm. That is not great but it’s also not that bad. Ideally you want that to be less than 0.5 mm. But the mesh leveling should be able to compensate for you easily.

It is probably not worth the effort to follow the steps to manually re-level aka Tram the bed at this point. But it is an option.

The reason this chart shows both Plus and Minus numbers is because they are using the center of your bed as the 0 point.

1 Like

Thank you Nikoli,
But what I was referring to was the RAW sensor data. Not the bed level mesh report. If you read through my previous comments you will see that I can’t even get the printer to Home Z or measure the mesh. Because one or more of the strain gauge foil sensors attached under the bed heater are generating an error. I was asking if it is possible to view that raw data to be able to help me pin point the problem.

@Mordiev ,

Thank you for that information. Trying to understand here… :stuck_out_tongue_winking_eye:

I think I messed up because after I took this picture I clicked on “Clear bednet data” and the color chart disapeared… :frowning: How do I get that back…?

Just run the bed level self check. No need to run the input shaping one that takes 10.

Got it… Thanks… :+1:

The only way you would be able to obtain accurate raw data is by rooting the printer and then accessing via Fluidd or Mainsail which will allow you to monitor the console for any data.

The console will report back what the parameters are of each probe point but is only possible by rooting the printer and installing Fluidd/Mainsail.

After I do that how would I adjust the parameters so they are within tolerances…? Mine now shows +1.3743 ---- -0.2671

A little worse than the last time… :frowning:

You are pretty much within the tolerances needed @jimandyen, anything within 3mm between the highest and lowest point should be fine as the printer moves the bed during the print to compensate for any slant/offsets.

If you want to try getting your bed as level as possible I would recommend the after sales video for levelling the bed. It might not get you 100% level but will get you closer to 0 on all corners so that you have a base point to work from. Mine was 1.6mm variance when I received the printer, after doing the belt in the base mine is now approx 0.5mm variance. It took a couple of goes to get the belt right but patience pays off :joy:

Service Tutorial K1 How Bed Leveling

1 Like

Well I’m going to have to take my bravery and patience pills then try it. Thanks for that info. I was using the WebUI of the printer to see those numbers. Are they not accurate enough to use… I want to avoid rooting this thing if possible…

This would be the same as for the K1 Max I would imagine…right…??

You’re welcome @jimandyen, you will be fine its not as daunting as it seems :slight_smile:

The values from the WebUI are perfectly fine and accurate enough to use. My comment above regarding accurate values via rooting was in reference to Mordiev’s question about raw sensor data.

In your case you will be fine to use the WebUI info as a reference :slight_smile: you should find the Creality tramming method will get you close to level, you can then tweak or adjust as needed.

First time I did the belt it went from 1.6mm to 0.9mm, then once I had re-adjusted a second time I got to the 0.6mm range by nudging the belt round by one tooth. Please whatever you do don’t use the so-called “tooth skipping method” that’s going around online as its not good and risks damaging the belt.

I am not going to tweak mine anymore as I am more than happy with a 0.6mm variance :slight_smile:

1 Like