New Ender 3 V2 Neo wont update Firmware

I got my first printer the Ender 3 V2 Neo a couple of days ago, and i have tried to update the firmware but it just does not update. I have used 2 different SD cards now and nothing works. I have tried quick format and regular format. I have my format settings on fat 32 and 4096 bytes. I have tried to rename to bin file several times. I have tried a lot of different firmware updates, but nothing works. Please help me
Thanks :slight_smile:

Hello there @Gingergamer425
Welcome to the Creality ForumCreality

Does the printer need the firmware update…? What I mean is will it print anything or is it stuck on firmware update messages…?

Hello @jimandyen
It still does print. But I though that a firmware update would help it print better and faster.

Generally they recommend not to update the firmware if your printer is working just fine. You can however read about the firmware and see exactly what it is supposed to fix or improve. I usually wait to see if others are having problems after updating which sometimes happens…

1 Like

Oh ok then.

Have fun and enjoy the Neo…

Thanks and I willl have been :slight_smile:

also if you use the creality app you can view your printer(s) in the workspace tab.
if any updates ate available you can click update and the app takes care of it, no need to use an SD card etc.

I had a problem as well with the firmware update. It boiled down to the microSD card. Furthermore I received instructions from the selling company in assisting me by providing me with a link to a youtube film regarding the update

Which als was very helpful.