Creality Print not connecting to printer

My Ender 3 V3 KE is no longer showing up under devices in Creality Print. The printer is online and is showing as online in Creality Cloud. If I look in the personal center in Creality Print, I see the printer under devices, but it shows as offline and disconnected. It I attempt to manually add the printer using its IP address, I get a message that it cannot be found. I am using the latest version of Creality Print for Windows. I have uninstalled Creality Print completely, clearing all config files, and reinstalled, but it still does not work.

It sounds like network connectivity to the app may be blocked by Windows or possibly antivirus software. To check if Windows it blocking the app do the following…

Click Start Menu and then type “Windows Defender Firewall” and hit enter.
Select “Allow an app or feature through Windows Defender Firewall” on the sidebar.
Select “Change Settings” above the list of apps.
Scroll down and locate “Creality Print” and ensure the relevant boxes are ticked.
Select OK to save the changes.

UPDATE: It just started working again, leading me to believe there was an issue on the backend
What is odd is that it used to work fine and now does not. This occurred sometime between December 8 and today. I had to manually add CrealityPrint to Windows Defender Firewall exceptions, but it is still not seeing my printer. I tried completely uninstalling 4.3.7 and then installing 4.3.6 and when I went to personal center, my printer was showing as online and connected. However, when I updated to 4.3.7, it stopped working. Very strange. I need to use 4.3.7 as that has the profile for the KE. I tried uploading to Creality Cloud, and while it showed it was uploading, when I went to Creality Cloud, nothing was there. It is as if Creality Print is not connecting to Creality Cloud.

A new version of Creality Print (4.3.8) is now available which may solve the issues you are experiencing.

Here is a link to download the latest version if you would like to try it…
Creality Print - Release V4.3.8

1 Like

Thank you! I will try it! I really appreciate your help.

1 Like

I installed 4.3.8. The printer is connected under devices, but still shows as offline and disconnected under personal center. Very strange as this showed correctly in 4.3.6. There is still some disconnect between Creality Print and Creality Cloud, but at least it works for wireless LAN printing.

Thanks for the feedback regarding 4.3.8.

I am wondering if there is some work going on with the cloud side of things as a few customers have mentioned over the past 24 hours that there were issues when trying to monitor their systems. Hopefully the issue will be resolved soon.

1 Like

Interesting, but good to know I am not the only one having issues. My speculation is:

  • a change was made on the backend to go along with the 4.3.8 release to make that version work better with the cloud side, but that change made it incompatible with version 4.3.7 (which is the one still showing on the Creality website)
  • fixes to try to address cloud connectivity issues post 4.3.6 introduced new bugs the impact how devices appear in the personal center and those bugs remain in 4.3.8.

As far as I know no changes were made to the backend, the only changes that were made were within the slicing software itself.

As a general rule the slicing software is designed to work for LAN printing and as an alternative to using the cloud to upload the files etc. The slicing software is not really designed as a cloud interface, more of a local LAN interface for the printer.

1 Like

Got it. I was just speculating why it stopped working and you said you were wonder if something was going on with the cloud side of things. In any event, my LAN printing is worthing again with 4.3.8. Once my Nebula Camera arrives I will be all set. This is an amazing printer at a phenomenal price. I think my friend with a Prusa MK4 may be a bit envious. Thanks!

1 Like

You’re very welcome. Glad to hear everything is working as expected on 4.3.8 :slight_smile:

The KE is a magnificent printer and so glad to hear that you are enjoying it :smiley: I have the K1 but I do quite fancy a KE too :joy:

1 Like

I have a similar issue. I installed v4.3.8.6984 of the Creality_Print tool yesterday and my new Ender-3 V3 KE showed up and WiFi printing worked just fine. Today the printer just doesn’t show up in the Devices view and can’t be found with “+Scan Add”. However, the printer shows up as online in the Cloud portal and starting print jobs from there works. The firmware is up to date, I have already restarted the printer, router and PC, Firewall settings are ok – I even opened up the gate temporarily to check, if that was an issue, but it wasn’t.
Any useful tips will be appreciated. Thanks.

Hello @No.87
Welcome to the Creality Forum Creality

I don’t know if this will make a difference but make sure you are logged in to Creality Print. I noticed every once in awhile it logs me out when first start up.

Logged-In

Hi there,
Yes, I did check that. I also removed the CrealityCloud connection AND the WiFi AND reconnected both, but still no improvement.
Another thing I tried was checking the local network connection from a different laptop, that worked in the past. The same situation as well.
Maybe because it’s Tuesday…

Yup Tuesdays can be one of those days too… :stuck_out_tongue_winking_eye:

Any luck manually typing in the IP address of the printer…?

I tried that of course. But all I get is a messsge that reads 'The printer could not be found!

Idea… :thinking: :bulb:

On the printer disconnect from the WIFI and then reconnect it again and see what happens…

I have the same issue.
Creality print can’t find the K1 printer, and I can’t access the web for LAN printing.
I can clearly see my printer’s status in creality cloud, but the camera image is still loading.
help!

I am no expert, but have had to play around with this enough to have some thoughts. If you are connected to Creality Cloud, then the issue is not on the printer side. If it worked before and stopped working, then there may be an issue with the Creality backend or cloud side of things that could/should eventually resolve itself. Another option is to completely uninstall and reinstall Creality Print. However, if the issue is on the cloud side, that won’t solve the problem. There is a prelease version 4.3.9 that has some cool new features, but since it is prerelease, you may or may not want to try it Release V4.3.9 · CrealityOfficial/CrealityPrint · GitHub

In my case, I upgraded to 4.3.9 beta from 4.3.8 as @bschust said.
But unfortunately, nothing happened. :frowning: