Ender 3 v3 SE is not showing print data and printing for new files

Can anyone help me?
I’m new to 3d printing (i got my first printer 3-4 weeks ago) and i encountered a problem that my printer isn’t showing any print data and just showing “0” for everything. Once i actually start printing it does not extrude properly (not really sticks either) and this only happened to the new files i put in my sd card.

Have you tried a different SD card to see if that shows the files?

Filament not sticking could be a few things. Make sure the build plate is clean, use washing up liquid/water, like doing the dishes, this will get rid of most of the dirt, dry it off thoroughly then give it a wipe with isopropyl alcohol, this will be as clean as you can make it. Avoid touching the build plate with your fingers, finger grease can stop adhesion, good practice is a wipe down with isopropyl before a print. If it still doesn’t stick then you will probably have to adjust the z-offset a little, I have to adjust mine down by 0.05mm for a good first layer.

Will try now!

Every other print is working except for the new files i added

Short filenames with no special characters?

Yep, one of the files is just 3 letters

I think its working now because its printing fine so far (i started a print) but it still shows the “0” for every thing so i think its a software glitch

Never mind, i don’t think its extruding properly because it broke