Ender 3 V3 SE Nebula Smart Kit Install Issue

I am pretty new to the whole 3D printing world.

I bought and Ender 3 V3 SE and later decided I wanted to upgrade it with the Nebula Smart Kit.

I followed the directions and even formatted the TF Card before putting the new files on it.

I continually get the message “Machine motherboard communication anomaly.”

I chatted with support who gave me what they claim were the “newest files” and i get the same error.

Has anyone come across this and what did you do to fix it? Should i just return the Smart Kit to amazon?

Unfortunately, I figured as much.

Appears there is no help on this.

Now I’m stuck with a pretty much new unusable machine.

I ran into the same issue on mine on installing it tonight. I turned off the machine, unplugged and re-seated the connection. Then it started to work. Not sure what troubleshooting steps you took but hopefully this helps.

Wish it was that simple for me. I’m starting to feel like they just throw crap out without testing their products first.

Right now I can’t even put the old screen back on it and use it.

So right now I’m stuck with a brick.

You have to reflash the original firmware to use the old screen again. Mine was a simple upload and plug and play

Where would one get the original firmware? Creality pushes their current firmware no matter what.

NVM, i got the old screen working. Wonder that the deal is with the Nebula Smart Kit then.

The marlin firmware not the nebula mate I meant.

Not too sure maybe check your screen cable isn’t loose to the MB

I wonder if there is an issue with the screen not getting its firmware update. Does anyone know if the screen and be plugged into the computer to get its update?

The nebula screen can be updated via usb from memory. Check out GitHub for instructions

Finally worked. Not sure why this time was the charm but it did.

Thought I did it the same way the past 15 times.


  1. Go to the download center, eco systems, nebula smart kit and click on the 3D Printing Firmware; Download and Extract.
  2. Take the SD card that came with the machine format it in FAT32 with 4096 for unit allocation.
  3. Only put the ender 3 *.bin file on the card.
  4. Put the card in the machine with the Nebula Smart Pad attached. (DO NOT HAVE THE G SENSOR ATTACHED)
  5. Turn on the machine and follow the prompts on the Smart Pad.

There are videos out there, even ones that Creality recommend to follow that have you attaching the G Sensor and following prompts on the smart pad before turning on the machine, that do not work appearently.

1 Like

So it appears the Nebula pad does not like Cura G Code? every time i try to slice in it an load, it fails.

What’s the error you are getting it’s probably a g code that’s enabled in your scooter that’s incompatible with klipper

On the machine its unknown, if i upload it to the cloud it claims it wasnt set up for the machine.

Also starting to notice layer shifts after the print is about 50%.

1 Like

im having this same issue, same error. same failed prints. i could only upload the bin files your way. maybe theres another way where the printer and the nebula pad will have better understanding of each other. if you get any further on this im working on it today

I have not figured anything out at the moment.

I will add to MikeTX’s instructions. Mine refused to flash until I did exactly what he said and did not have the USB stick inserted into the Nebula Pad. Until I removed that and followed his instructions it would get stuck on “Connecting…”.

Layer shifts are bad vref settings on the stepper motor I remember reading about it on reddit I think it was .6 on the y I’ll see if I can find the post again for you.

As for the errors do you have arc welder enabled as klipper doesn’t know g3 comments and even if you put it in your config to enable klipper just converts them back so it’s a bit redundant

This worked for me. Thanks. This issue was really frustrating.