Overall startup failure and Error Key 2000 - Ender 3 V3 KE

Hi forum!

I received my Ender 3 V3 KE unit due to Creality’s awesome sale over Christmas break!

Upon arrival, and after the unit was put together, and after a smooth assembly…the unit was ready to boot up and test.

For unknown reasons, the PSU receives and outputs power HOWEVER the motherboard cannot for whatever reason supply connection power and data to the digital interface. The PSU does indeed output correct voltage.

Here is exactly what occurs:

  1. Power on Ender 3 V3 KE unit
  2. No power to display while the unit is powering up
  3. To get power to the display, a 2A connection from a USB computer port to supply data and power from another computer interface is attempted to see if it’s a strange driver issue ect
  4. The computer OS recognizes the unit for a “quick second” then unregisters the unit “Unknown peripheral connection”
  5. During this connection process the screen is stuck for almost 2 minutes on “Creality” Logo
    6)After the “Creality Logo” disappears, then “Machine-startup in progress” overlays on top of the following error:
    “Key 2000: An unknown error occurred during the printing process”
    7)The screen becomes stuck with no ability to register, change or alter any configuration.


  1. What is a Key 2000 error?
  2. Why would an external data/power USB connection to this display be necessary where the motherboard is unable to send this unit power?

** Both the motherboard, the display and the data/ display cable are new - doubting the MB would be defective. **

And yes the mains is on correct voltage!

Hoping to have an error code expert on the forum. I’ve “goofed off” too long trying to troubleshoot this one!

Unfortunately the description for the error codes if any are pretty vague.

I wouldn’t rule out motherboard as those things don’t always have the best QC.

If it were mine I would go inside and check all the connections to make sure they are firmly in their place. We’ve seen connectors placed in the wrong sockets or backwards coming from the factory so you never know… :cry:


Hi there! This is my first post and I hope that my communication is OK on here. Please lmk if anything is out of place or not per forum ettiquette!

Also - thank you for the reply! It appears after thorough research, all of Google returns nothing for the error code on this particular unit. That’s tough!

It did take some doing, but a second MB has been installed for testing. Same error. The chances of (2) MB would be extremely unusual! The issue does not appear to lie with “boot loader” instructions…unless my assumption is quite incorrect! Basically, absolutely “0” voltage comes out of the large ATX “brick” connector. New to 3D printing! What does this mean??

If it is a second MB that’s no good…what are some testing options on that? How can one confirm a MB is “no good??” Sorry to be so wordy here!!

You are doing great. No problem…! :+1: :slightly_smiling_face:

What is the ATX brick connector…? Power supply…?

The electronics involved here is way above my pay grade but I’m sure there are members here who know a lot more that would help out…

I will post a picture later when I’m near by the machine! It is the main attachment cable end - looks like the biggest “lego” rectangle. I’m sure I also have this name incorrect. Appreciate the input. Hoping for others to hop onto this thread!

That big green lego brick…? :grin:

Voltages? 115 v 230? Is the right one selected?

The key:2000 is a communication error between boards, you have two MCU’s on the KE. The main one that’s under the metal plate and the one that’s in the screen itself. You then have one :one:mire daughter board in the shroud. Given that the screen isn’t powering correctly I would tend to lead that it’s the connection between the screen and the board under the metal plate. Check those connections and that from the power towards them


My mistake! The connection on the bottom left!


Got it! Let me check and see what’s going on with these voltages, I think? Hopefully I can figure this out. Still new to this!

I have same machine and same error code. I got in touch with Creality support fist via email and then via Messenger on Facebook (they are active GMT+8) . My issues started after about a week when I started to notice a strong plastic burning smell, after a day I decided to have a look under the hot end shroud and sure enough the hot end was blackened in places. There are 2 wires feed I assume voltage to hot end but these do not look like in their video , they have extensions on them and connect via solder to the front of the unit rather than the back as shown in video, also the last 20mm of the extension wires are exposed copper and sit around 1mm from each other. I think that when removing and replacing the silicon heat shield there is a strong chance these expose wires will touch and damage something or at the very least blow a fuse. Anyway, top and pottom of my story is Creality are sending me a new board and hot end, I will post again when it comes and is fitted see if that is the issue. The support guy was very good on messenger, could not fault.

Has the question that Bonfireman asked been answered yet?
Is the printer slide switch set up to work off 115vac or 230vac?
This is the first thing that needs to be looked at when setting up a new printer in the USA because the printers are set to 230vac when shipped from the factory.
According to creality tech support this is the number 1 reason for issues that newbies have. :grinning:

@Cr31ity_4 mentioned that he did check in his original post. :+1:

Always need to check that first…!

Was on the Creality FB page the other day and someone had their machine set on 115V and they plugged into a 230V supply, the magic blue smoke escaped from that machine. Expensive mistake.

Hello All! It’s rather odd the focus is on the voltage setting here. This is the most common thing to check when getting a new unit. This was checked. And with the addition of a second motherboard that is brand new from factory, again, it is extremely unlikely it is the motherboard that’s failing here. @BOXXXUK - The issue here is nothing, and I mean absolutely nothing functions to even get to the point of actually even being able to use this unit. To even get to the point of a “test print” would be great. The issue appears to be data related. As thoroughly pointed out by @amberhelios appears to be the connection from the board to the screen. If voltage is applied from the PSU, and the Voltage has a pressure of 120V, then surely there must be some type of processing error. Is anybody experienced enough to work with peripherals on these boards to test? This brand is absolutely awesome. There must be some way to troubleshoot this! And please do not take this as frustration at you. Some of us have serious overhead and our livelihood may depend on the success of this brand functioning…

1 Like

So replaced hot end with micro swiss one and still getting the same (warning key: 2000) . Creality said they will send me replacement motherboard and hot end guess just need to wait until these come then if no joy RMA :frowning:

I’d check the cable that goes to the display.

Looks like the MCU in the screen is stuck or broken. Went through the wiki stuff on how to unbrick but instead of showing up when connected to windows via the internal usb it showed as unrecognised device so it is useless. Creality is sending me another one, meanwhile I have had to buy another machine as time is of the essence in what I am doing and cannot wait for parts to come from where ever.

Hi All, I only found the below so far.

I have this exact problem only had it 9 days.