Problem with Ender 3 V3 SE home


Due I haven’t received any answer Creality support team (more than a week waiting for an answer) I’m writing this post so that someone can help me.

I bought my ender printer at the end of December and I receive it on January 5th. Once I assembled it correctly I noticed that, when the 3-D printer starts calibrating It doesn’t start from the usual home coordinates, but from a different place, compared to other users that I’ve seen in YouTube for sample .The printhead goes along the right side of the mat, and when it arrives to the end It seems that it want to continue, but then suddenly stops and makes a strong and weird noise.
When I printed the default model, instead of printing it in the centre of the mat, it printed it in the right side. It hardly goes to the left side

My conclusion after these days investigating, because was that its home coordinates are wrong.

I don’t want to try to change the Marlin code because the printer is still in the guarantee. And if I do it, maybe I won’t be able to request another one because of that.

Can anyone help me with this problem? I’m quite desperate on people from reality don’t give me any response.

Thank you!

Hello @aquestion29
Welcome to the Official Creality Forum Creality

See if this is your problem:

Auto Homing

1 Like

To the left side of the printhead there is a limit switch and on the left end of the x axis there is an end stop point for the limit switch. If you push the printhead to the left does the limit switch hit the end stop before you can’t move the print head any further? I have noticed that when the x axis is raised all the way up on the z axis the print head cable can foul the frame. Any chance you might have something fouling to the frame? Not hitting the limit switch points will probably give a fair amount of grinding noise.

1 Like

I think you explained it better. Thanks @Bonfireman :+1:

1 Like

Hello @jimandyen ,

Yes, that’s what happens but in the other direction. In the video the person contacted creality and the answer they gave him was skip the auto home… I’ve been trying to contact them but no response from them :frowning:

I can’t find any assembly fail.

What can I do?

Thank you very much for your help

Hello @Bonfireman ,

I can only see these switches on the print head and ant the en of the bed mat. The printer is completely new, and is not dirty. Also the printed head haven’t reach to the top (up) and right , because it has only printed the cat.

The problem is still when the printhead goes to the right and crashes with the end of the axis.

Sorry for not adding any video but im a new user

Any ideas?

Thank you very very much for your time and response

As you can see, if I move the X axis to the 0.0 it stops there, and not in the far left side

Can you do a reset on that thing or some kind of homing calibration… ??

Maybe something in this blog would help:


I don’t know where can I make that home calibration… I can’t find any option like that in the screen menu. How do you usually do that?

Thanks again, I really appreciate your answers

Slightly different layout on the SE, might see if can get some pictures to further help.

1 Like

Excellent blog, well worth bookmarking that. Doesn’t mention too much on the limit switches though.

Can’t move the end stop as it is part of the moulding that takes the pulley. I’ll have to have a look to see if there is slot tolerance on the limit switch. If it homes correctly it shouldn’t crash into the right hand pulley housing.

1 Like

@Bonfireman @jimandyen thank you guys for your help.

I was thinking that I could be probably a problem of the default origin of the printer.
Because the printer starts in a different part than usual (centre) maybe its X,Y,Z (0,0,0) are offset in X axis and its real X,Y,Z are, for instance, (5,0,0) and that’s the reason the printer hardly goes to the left side of the mat and thinks that once it arrives at the end of the X axis it can continue but collapses.

What do you think? It’s a bit dissappointing because it’s something that must be well coded from factory and we don’t have to be the one that fix it.

Thank you again for your help!!

Bit confused the home for X is far left when it hits the limit switch, home for Y is right at the back position when it hits the rear limit switch, it will then stay far left and traverse to the very front of Y. No need to Z home if it is all Z calibrated. Not had a X crash on the right of the X axis, but I do get a Y crash on both my SE and 5 plus but they’ve never caused a problem just a brief graunching noise and then finish. I’m still interested if your X axis properly homes.

Looking at your cat print, the initial purge line should be over to the left not in the middle which is why I don’'t think you are x homing correctly.

Hello, new to community.

Saw this post and had identical issue out of box. I’ve worked with CNC machines for decades and started with 3D 4-5 years ago.

Anywho…. I have noticed that a LOT of Creality firmware has a flaw. It affects homing properly.

Try this please. It will not hurt anything.
1- Turn off printer… for 2 reasons. It will not record any manual movements made and the stepper motors are not locked.

2- manually move all 3 axis’ to their proper home position. Slowly as not to create a significant amount of electrical current ran back to the main board.
If you take your time, listen for limit switches, you will now have everything in position.

3- Turn machine on. Before you hit/move/change any settings, watch and listen.

If all is well, NOW go to “home” setting and have it auto home itself.

Please let us know if this makes a difference. Wether it’s the same, better or worse. Then I/we can go further with help.

When I first started mine up the print head started to beat itself against the RS X axis…… just like yours. I jumped to pull plug from wall…. I thought it was defective or ruined. It’s been working excellent ever since I realized that most of the firmware versions THINK it’s in the home position at startup. If it’s within 25% or under away from home, the auto home feature seems to work okay. I’ve also found that the closer you manually move it to home while off, the better it homes and the need to do so in future is far less often. That’s my experience with exact situation. I can’t guarantee it’s your issue as well. But it’s worth the try.

Listen carefully for home switches to activate. If you do hear them when in position, then when you home it, if it beats against the left side, the switch may be faulty or when the board was assembled they swapped connectors in wrong sockets. This also happened to me on an ENDER 3 years ago. Unfortunately on that one it wasn’t the limit switches. It was the X axis and Extruder. I tried checking/setting the extruder steps out of box and the X axis was beating itself against the LS that time. The axis cables aren’t your issue obviously. But if any of the axis’ are grinding against the switches in your case. It’s worth a look at cables.

1 Like

Nice post Superman. If I were to redesign the Creality printers I would probably put limit switches at both limits of movement. Totally agree with you put the machine in what should be home position and then let it go through the startup procedure. My Ender 5 plus threw a wobbly once where it didn’t know where home was, did as you said and it has been fine since.

Hi @SUPERMAN31170 thank you for your tips. I’ll try them all this evening and I’ll give you my feedback.
Btw how long does it take to the new users upload videos in this forum? That would be easier

Thanks everybody for your help!

Very welcome. My first post here was actually my first post in this community. I’m not sure how long it takes on the videos. I’m curious as well. I’ll attempt to locate the information for both of us. Has to be buried somewhere in faq guidelines.

@Bonfireman, you’re absolutely correct! All of my CNC equipment has limit switches at both end stops for all 3 axis’. Huge difference! It would eliminate so many issues on 3D printing.

@SUPERMAN31170 good news and updates!!

I tried your tips of moving both the extruder and bed to the closest position of the 0,0,0 origin of the printer. The bed moved to the end as usual but the extruder moved to the centre of the mat, it didn’t collide with the end of the X axis!!!
However, in that position, I tried again to auto home , and it made the same wrong thing, colliding as usual with the end of the X axis.
I’m attaching some pictures in order from step 1 , moving everything to the origin , to step 4 ,after autohome.

Next thing I’m going to do is to print something again to see if it makes it in the centre of the bed.

Superman, this means that I have to do this every time I want to turn the machine on? Is there any option to fix this problem? Why and how do 3D printer have this problem?

Btw, Creality support team have completely ignore me and my query after more than a week insisting them… I feel terribly disappointed

You guys have helped me a lot, you’re amazing!

Before printing anything again I would like to read your comments :sweat_smile: