Problem with Ender 3 V3 SE home

Thank you for your comment and also so sorry for what happened to you. I can see that this is the way they work.

I can totally relate what are you saying… this is unacceptable. However, I contacting them, sending emails and I’m not going to stop doing it until my warranty period spires, I don’t mind being sending two or three emails per day during one year … let’s see what happens!
I feel scammed, I will support any campaign against any creality product.

1 Like

I see… that’s true because the quality of the cat was quite good. The problem was that it printed it too far from the centre (which is the default place when you print something) and I compare with other users on youtube.
Lot of things are wrong, and for a person who has no experience in 3D printing like me is a punch in the face

I understood even before watching the video. Video helped anyway. I can now see the firmware is parking it in the wrong position and not allowing to zero it through software. Firmware/software is the same thing with the exception of “Firmware” is coded onto machine. It’s just a term we use for any electronic device not being controlled by an accompanying computer.

Earlier you were concerned with changing software/firmware and warranty. It’s fine, I read their warranty and directions for your machine. In fact, they actually tell you to upgrade firmware after you assemble the printer.

We need to find an updated or different firmware for it. If it has latest firmware, we can try re flashing it.

I have found the firmware. I’ll post a link and pic here for you to download.

LINK:

It’s the top most recent firmware for your machine.

I’m guessing they included the usual SD card since you are using it to print cat.

1- Turn off machine

2- put SD card in your pc and remove all print files. You can move them to your pc if you want to save them. Just make sure to delete them from card.

3- Rename the Firmware file you downloaded to “firmware.bin” .

4- Eject from pc and put it back in the printer with power still off.

5- Turn printer back on and wait. The screen may stick for a moment or look crazy. That’s normal. May just stay blue. After firmware updates, you can look through and see there are more options and information now.

Now we can see and do the things we have been trying to. I don’t know why they would ship that printer with such an old reportedly buggy Firmware. Unless it was sitting on a shelf forever somewhere since manufactured.

Come back when you have time and let me know what it looks like now. What options are added and if you can now zero it through the on board interface.

Just wanted to say a quick thank you for all your time and effort helping to assist a fellow member! It hasn’t gone unnoticed and just wanted to show some appreciation for your contributions to the forum and community. So great to see members assisting and helping out others :hugs:

Thank you Nikoli, hopefully I’ll get him up and running soon.

1 Like

@SUPERMAN31170 , before doing it, I think I have the last version of my firmware…


Actually, when I printed the cat , I had the V1.0.4 firmware, and during the last couple of days the only solution that creality gave was to update de firmware to the V1.0.6

Every tip I tried from you was with the V1.0.6 firmaware… :confused:

Let me know what you think about it, cause maybe you’re telling me other different way to update it

Hi @Nikoli ,

I must say that @SUPERMAN31170 is being incredibly kind with all the support that is giving to me.

Is there any option that you Nikoli can show this topic to any Creality support colleague? I’m desperate

Did you managed to use an Ohmmeter to see if it is not affecting the Head Limit switch?

I’m wondering if you can plug an Octoprint instance into your machine and from console send HOME command to see what you get back as a response.

Can’t test on mine since it is printing but will try after.

Try the firmware I linked. V1.1blah blah blah is a newer version than 1.0. blah blah blah.

I checked the firmware you have in video’s you posted before I checked all available firmware.

I posted the newest firmware after reading extensively through the whole change/bug fix list. It is supposed to have bug fixes that may be related to your issues.

The version for firmware I linked is only 3 days old.

Linked firmware is for KE, for SE already has the newest.

I saw that, but it’s stated elsewhere that it’s compatible and updated.

Do you or anyone else know if that’s the case by actual use?

I’m going off of information others have said it is compatible and it did help them.

I don’t use either of those models or have immediate access to them to check myself.

I myself use firmware for a completely different machine that implemented many new features and improvements.

The firmware posted is supposed to be able to move all axis’ from the screen manually without auto homing first. Which is what I’m trying to have him do. If so he should be able to set it, save settings and possibly check X axis switch without an ohm meter. He still hasn’t let me know if he has access to one or knows how to use it.

Sorry, but i don’t have any ohmmeter…

If the KE firmware is compatible i’ll give it a try . I’m I bit worried if that can damage my printer or if I is it possible to go back to the V1.0.6 if doesn’t work

hi @Iroh3d

let me know when you try this. If I don’t have any choice, I would try to find a ohmmeter and check that.

As a new 3d printer user, I don’t have any tools like that

Shouldn’t cause any damage. Uses just about the exact equipment your printer does and you can always go back to current firmware.

1 Like

For Homing Operation I’m receiving on Octoprint’s Console the following output and reports back the coordinates:


Send: G28
Recv: echo:busy: processing
Recv: echo:busy: processing
Recv: echo:busy: processing
Recv: X:134.25 Y:125.00 Z:10.00 E:1.68 Count X:10740 Y:10000 Z:4000
Recv: echo:Bed Leveling ON
Recv: echo:Fade Height 10.00
Recv: ok

I tried to move X Axis to press the switch so the code in my SE to press it is:

G1 X-14 Y110

You can try to do the same and see if the negative value corresponds to the same as in mine but if it stops as it is doing now without reaching the left end of your gantry, you will need to get an Ohmeter(there are very cheap on amazon) to check the switch and probably check the MoBo too. Because if the coordinate itself is not reached seems like probably is not a software issue, I’m running the same firmware version as you do and is working as expected.

I went through schematics of the board and print head assembly.

On the cable going to print head, the X axis signal wire is to the far left.

I also found a side note saying if the cable isn’t attached exactly parallel to the input before installing cover/clamp it may not read the X limit switch signal specifically and will not travel to the left/negative direction during homing.

It’s worth a couple minutes to make sure the cable is correctly oriented in print head. Especially if Iroh3d’s test points to limit switch issue.

1 Like

@Iroh3d @SUPERMAN31170 ok I’ll firstly check the cable.

I don’t know how to use the ohmmeter but I’ll do my best. Any tutotial will be welcome!

I will also ask you how to check the mother board and all mentioned :sweat_smile:

I’ll keep you update as soon as possible

Thanks a million!

Ohms are a simple function/test with a meter. Even a $4 Harbor Freight meter will be fine for ohms and volt purposes.

Your switch will be similar to the one in picture. If you look at the switch itself you will see it has 3 poles.
One marked C, for common, one marked NO for normally open and one marked NC for normally closed.

You want to unplug cable, hook ohm meter to the C and NO poles.

With ohm meter set to ohms (usually looks like sideways Wi-Fi signal graphic) hook to the C and NO poles of switch.

When not activated (not touching X home position) you will see no change on meter.

If you push the button/lever down, the meter should read close to zero…. Some cheap meters and cables they are supplied with will not show absolute zero. But it will be close.

If the meter reads close to zero before activating switch, the switch is stuck in closed position and faulty.

If it reads open (no change in meter reading compared to test leads not connected to anything including each other), then reads closed (or close to zero ohms) when it is pressed means the switch is working as intended.

This sounds simple to me, but if confused just ask further questions.

EDIT:
It’s unclear in any information I can find on your printer if it also takes a reading for open position. I don’t believe it does. Just to be safe, you can test that as well.

Just hook meter to C and NC poles of switch.

It will show opposite results. When not pressed it will show close to zero on meter. When pressed it will show open on meter.

I agree with @SUPERMAN31170 on the flashing of new firmware. My logic here is that clearly his current installed firmware is dysfunctional. Even if he flashes the exact same version, it won’t hurt to be sure he’s got the latest file that he himself installed. AND even if it’s the wrong firmware, he can just reflash again with a different firmware right? Worth a shot. After all, it’s not working properly anyways.

Checking the limit switch first would be smart as well.

–After we’re done fixing @aquestion29 broken printer, let’s all try and fix my Ender-5 S1 that’s still under warranty :rofl: I call dibs on the next troubleshooting. —

1 Like

Agreed on the dibs, lol